Weiter im HTPC Kreuzzug

Als begeisterter User von XBMC hab ich die Mission „Persistenter Speicher in XBMC Live“ endlich abgeschlossen und die config Dateien, die ich nach dem booten bearbeite, bleiben bestehen (indem ich mit Toporesize eine ext3 Datei erstellt habe und danach von live-rw.img in live-rw umbenannt habe).

So weit so gut.

Seitdem ich allerdings einen neuen Internetzugang habe – ADSL der Telekom statt UMTS (GPRS beim Haus) über Drei – funktioniert mein WLAN unter XBMC Live nicht mehr.
Mit dem UMTS Router (Huawei E960) klappte der Zugang, sofern ich die interfaces Datei bearbeitet hatte. In diesem Fall stand der Router aber auch im selben Raum wie der Revo und die beiden konnten sich über Sichtverbindung freuen. Das ist bei WLAN natürlich nicht notwendig, half aber in diesem Fall enorm. Wie enorm, musste ich dann nach Installation des Pirelli Modems erfahren.

Das Internet über die Telekom läuft mittlerweile (nach einem Anruf bei der Hotline) mit 3.3Mbps, was okay ist für meine ländliche Umgebung. Am iPhone klappt auch alles super, habe immer dementsprechende Werte und im ganzen Haus Empfang.
Auch die Wii kann sich problemlos mit dem Pirelli verbinden, wie schnell die Verbindung ist, kann ich hier nicht messen (glaube ich, muss mal schauen).
Das WLAN am Revo mit Windows Vista ist vorhanden, aber mitunter zickig. Wenn der Empfang da ist, gibts auch hier Werte von ca. 3.3Mbps. Die Leistung ist aber schwankend und manchmal fällt die Verbindung ganz aus.

Bei XBMC Live (am selben Revo, mit dem selben eingebauten WLAN Adapter) will das Ganze aber nicht so recht. Die Einstellungen stimmen, beim Scannen wird der Access Point manchmal gefunden, manchmal nicht. Adapter ist konfiguriert und hat eine fixe IP. DHCP Lease (bzw. Host) wird nie gefunden, wenn DHCP eingestellt ist. Ping zum AP oder woanders hin klappt auch nicht. Das passiert alles im Terminal – und in XBMC gibt’s dann halt keinen Internetzugang. Damit wird das Aufbauen der Bibliothek schwierig, außerdem würde ich auch gern den Firefox, Launcher, Addons, Skins etc. laden können.

Leider ist die Position des Pirelli zum Revo so, dass ein Netzwerkkabel sehr lang sein müsste und extrem stören würde.

Aber da ich XBMC nicht unter Windows betreiben will (Vista nervt mit dauernden Update Anfragen – die sich nicht alle abstellen lassen und dieser depperten Benutzerkontensteuerung, die sich schon abschalten lässt, aber trotzdem), war ich auf der Suche nach einem anderen HTPC Betriebssystem. Getestet habe ich element und Ubuntu 10.10 Netbook Edition, wo ich dann wieder XBMC als Autostart laufen lassen wollte. OpenELEC.tv habe ich auch angetestet, das bootete gar nicht.

element war soweit okay, hatte sogar WLAN, wenn auch nur sehr langsames Internet, aber XBMC lief fast gar nicht. Das UI war so langsam dass es unbrauchbar war, vermutlich eine Sache des Grafiktreibers, aber damit habe ich mich dann nicht mehr beschäftigen wollen.

Ubuntu hatte eine noch langsamere Internetverbindung als element und ich konnte über das WLAN nicht mal einen Treiber laden. Da hab ich dann auch aufgegeben.

Tija. Bin also noch bei XBMC live 9.11 von XBMCFreak. Was ja okay ist, aber ich will XBMC live mit WLAN 😦

Werd mich mal (wieder) mit Basteln beschäftigen und versuchen eine externe Antenne dranzuklöppeln… (in etwa wie hier)

Advertisements

7 Kommentare zu “Weiter im HTPC Kreuzzug

    • whoa, also ob ich mir das ganze hickhack nochmal so antu… aber ich verweise dich voller überzeugung auf xbmc.org, dort lädst dann am besten die live version und packst sie mit unetbootin auf einen usb stick und bootest dann von dem.
      fertisch 😉 (im idealfall nat.).
      zum schnellen xbmc test gibts nat. auch eine windowsversion, aber windows starten zum fernsehen is halt doof. 😉

      • ja, aber du kennst scho alle möglichen probs &&& & bam 2. mal gehts eh sowieso schneller & sowieso und überhaupt hamma uns eh scho ewig nimma gsehn *g*

  1. Hi,

    warum fragst nicht mal im Forum von OpenELEC.tv oder im IRC #openelec auf freenode nach hilfe wenn OpenELEC.tv nicht bootet 🙂 Nur wenn wenn wir auf Fehler aufmerksam gemacht werden können wir die auch beseitigen 😉

    grüssle

    Stephan

    • Weil mir OpenElec.tv nicht so wichtig war. 🙂
      Und Fehler gab es ja keinen, es bootete einfach nicht, ohne Fehlermeldung oder ähnliches. Wie sehr hätte das den Entwicklern wohl geholfen? 😉 Vielleicht war sogar der Stick oder unetbootin oder der Bootmanager schuld.
      Wie gesagt, ich habe da dann keine Energie darauf verschwendet.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s